워드프레스 플러그인 설정 오류 해결방법

워드프레스에서 플러그인은 잘 설치되고 동작하는데, 옵션을 변경하고 저장할때 권한이 없다고 ‘You do not have sufficient permissions to access this page.’ 라는 메시지가 나오는 경우가 있다.

WordPress_error_You_do_not_have_sufficient_permissions_to_access_this_page

내 경우 모든 플러그인이 이런 문제가 있는 것은 아니고 설정 옵션이 있어서 변경하고 저장하는 경우에 발생하는 것 같다.

이 문제는  한국 호스팅 업체에서 보안상의 이유로 리눅스 기반 호스팅의 경우 Apache 버전이  Microsoft-IIS로 설정되어서 워드프레스가 서버 환경을 Apache 가 아닌 IIS로 인식해서 발생하는 문제라고 한다.

 

워드프레스 설치 폴더에 있는 wp-config.php 에 아래 소스코드를 추가 하면 정상적으로 동작한다.

 

 

내 워드프레스는 최신 버전인 4.4.2 인데도 2009년도에 기록된 문제가 여전히 발생하고 있는 것 같다.   보안상의 이유라고 하니 이렇게 하는 것이 좀 꺼림직한데 근본적인 해결방법을 찾으면 좋을 것 같다.

 

 

Related Post