워드프레스 플러그인 설정 오류 해결방법


워드프레스에서 플러그인은 잘 설치되고 동작하는데, 옵션을 변경하고 저장할때 권한이 없다고 ‘You do not have sufficient permissions to access this page.’ 라는 메시지가 나오는 경우가 있다.

 

WordPress_error_You_do_not_have_sufficient_permissions_to_access_this_page

내 경우 모든 플러그인이 이런 문제가 있는 것은 아니고 설정 옵션이 있어서 변경하고 저장하는 경우에 발생하는 것 같다.

이 문제는  한국 호스팅 업체에서 보안상의 이유로 리눅스 기반 호스팅의 경우 Apache 버전이  Microsoft-IIS로 설정되어서 워드프레스가 서버 환경을 Apache 가 아닌 IIS로 인식해서 발생하는 문제라고 한다.

 

워드프레스 설치 폴더에 있는 wp-config.php 에 아래 소스코드를 추가 하면 정상적으로 동작한다.

 

$_SERVER['SERVER_SOFTWARE'] = 'Apache';

 

내 워드프레스는 최신 버전인 4.4.2 인데도 2009년도에 기록된 문제가 여전히 발생하고 있는 것 같다.   보안상의 이유라고 하니 이렇게 하는 것이 좀 꺼림직한데 근본적인 해결방법을 찾으면 좋을 것 같다.

 

 







추천 글





0 글이 마음에 드시면 하트를 눌러주세요~ 블로거에게 힘이 됩니다 (SNS/로그인/광고 관련 없습니다)



당신이 좋아할 만한 글







연락처맵: 지도위의 고객관리
4.6
연락처를 지도에서 한눈에, 위치기반의 연락처관리, 내 근처의 연락처보기












Add a Comment

이메일 주소는 공개되지 않습니다.

























이 포스팅은 쿠팡 파트너스 활동의 일환으로, 이에 따른 일정액의 수수료를 제공받고 있습니다.



채널추가 버튼을 누르면 카카오톡 뷰에서 볼 수 있습니다.